SQL Server 2005 Attaching Database

12 May 2010 In:

Yeni makinamdaki SQL server'a eski DBlerimi mdf dosyalarından Attach yapmaya çalışıyorum ve aldıgım hata şu:

System.Data.SqlClient.SqlError: Cannot open backup device 'F:\foldername'. Operating system error 5(Access is denied.). (Microsoft.SqlServer.Smo)

Efendim çözüm şu SQL serverin servisini çalıştırırken login oldugu kullanıcının o klasöre erişimi yok, çözüm "SQL server configuration Manager" dan "Sql Server" servisine sag tıklayıp "Özellikler"den "Log On" kullanıcısını "Built-in Account"dan degilde "This Account" deyip admin yetkisindeki bir kullanıcıyı seçeriz ve servisi restart yaptıgımızca sorun çözülür.

MDF dosyasından direk Attach yapmak için ise cmd

sqlcmd -S . -U sa -P pAsS

gelen ekrandan ise 

USE [master]
GO
CREATE DATABASE [xxxlarB2B] ON 
( FILENAME = N'D:\Evlatlik2\projeler\xxlar\DBs\xxxlarB2B.mdf' ),
( FILENAME = N'D:\Evlatlik2\projeler\xxxlar\DBs\xxxlarB2B_log.ldf' )
FOR ATTACH ;
GO 


Bu kadar...

"Çalışkan bir çiftçiye çelik üretmeyi öğretebilirsiniz ama iş ahlakına sahip olmayan birine, çiftçiliğin iş ahlakını öğretemezsiniz. Ne yaparsak yapalım herkes içindeki potansiyeli kullanır."  - Jim Collins 

"Dünya yaşamak için tehlikeli bir yer; kötülük yapanlar yüzünden değil, durup seyreden ve onlara ses çıkarmayanlar yüzünden." - Albert Einstein
"Dünya; kötülük yapanlar değil, seyirci kalıp hiçbir şey yapmayanlar yüzünden tehlikeli bir yerdir." - Albert Einstein

"Eğitim, insanın okulda öğrendiği her şeyi unuttuğunda arta kalandır."  - Albert Einstein

Hayırlı uğurlu olsun

30 Nis 2010 In: .Net Micro Framework, hoş
Yeni web sitemiz çok az eksikleri olsada görücüye çıktı. Sitemiz üzerinden .Net Micro Framework ile ilgili tüm bilgilere ve cihazlara ulaşmak mümkün.

http://www.micro-framework.com

GHI ve DeviceSolutions firmalarına ait tüm cihazlara ulaşabilirsiniz.

Artık yanlızca DeviceSolutions degil GHI firmasınında ürünlerini bizden temin edebilirsiniz. 


Türkiye Distrübütörüyüz
http://www.ghielectronics.com/distributors

Eğer datalist içerisine koydugunuz bir button ve imagebutton, tıklandıgında postback yapmıyor ise, ki genelde bu hata yanlızca Internet Explorer IE de oluyor. Efendim maalesef postback yapacak yani command ın oluşması için sayfayı refresh etmesini şu şekilde sağlıya bilirsiniz.

protected void dtl_urun_ItemDataBound(object sender, DataListItemEventArgs e)
    {
        ((ImageButton)e.Item.FindControl("btn_sepete")).Attributes.Add("onclick", "javascript:__doPostBack('ctl00$ContentPlaceHolder1$dtl_urunumuz$ctl00$btn_sepete','')");
    }

Kullandıgınız control un adı ne ise ona eklemeyi unutmayınız, tabii ben burada master page kullanmıştım, o yüzden button un ismi bu şekilde,
sizin eklemek istediginiz çalışmayan ( not firing) kontrolun adını yanına bir linkbutton koyup ögrene bilirsiniz, browse ettiginizde üzerine geldiginizde javascript kodunu gösterecektir, onu revize edebilirsiniz. 
 Can alıcı nokta kontrolun adını databound oldugunda bilmek tıpkı ( benim imagebutton un adı  'ctl00$ContentPlaceHolder1$dtl_urunumuz$ctl00$btn_sepete' )

Yanlızca şu kadar

ALTER SCHEMA dbo TRANSFER YNS00009.CAR002 

artık database ile aynı olan YNS00009 shcemalı CAR002 tablosu DBO.CAR002 e dönüştü.

(Not : I was trying to change the 'schema' name on an object from 'username' to 'dbo' in SQL Server 2005.  )

 

Meridian/P için RS485 ve RS232 interface'i

6 Şub 2010 In:

DeviceSolutions firmasına ait compact developer kit olan Meridian/P üzerinde 2 adet UART bulunmakta. Bunlardan bir tanesi TTL seviyesinde RS232 ama DB9 formunda degil. Diger UART ıda endüstriyel uygulamalarda kullanmak için RS485 e çevirmek icap etmekte bunun içinde MAX3485 kullanıldı. Emeklerinden dolayı İlker beye teşekkürler.

Meridian rs485

 

Meridian rs-485

Kartın fiyatı : Meridian/p hariç 75$ dır.

Proxy arkasındaki Web Servisleri için

5 Şub 2010 In: .net, ipucu

Sunucunuzda bir web servisiniz var ise ve sunucularınızın önünde de bir proxy yerleştirilmiş ise " The request failed with HTTP status 417: Expectation failed " hatası alabilirsiniz, sebebi web sunucusundan istemci veri göndermek gerektiğini belirtmek için bir 100-Continue yanıt almayı bekler post etmek için. Bu mekanizma istemciler ağ üzerinden istek başlıklarına göre sunucu, isteği reddederek büyük miktarlarda veri gönderilmesini önler. 

Örneğin, Expect100Continue "false" ise İstek sunucuya gönderilir, bu verileri içerir. Eğer, istek başlıklarını okuduktan sonra, sunucu ve kimlik doğrulama gerektiren bir 401 yanıt göndermesi gerekir, istemci kimlik doğrulaması uygun başlıklarını verileri yeniden gerekir.

Eğer bu özelliği "true" ise , istek başlıklarını sunucuya gönderilir. Eğer sunucu isteği reddedmezse, gönderir bir 100-Continue yanıt veri aktarılabilir sinyalizasyonla. Eğer, yukarıdaki örnekteki gibi, sunucu kimlik doğrulaması gerektiriyorsa, o ve 401 yanıt gönderir istemci gereksiz yere iletilen veri yoktur.

 Web.config e bunu ekliyoruz ve sorun çözülüyor.

  <system.net>
    <settings>
      <servicePointManager expect100Continue="false"/>    
    </settings>
  </system.net>
 

Ben Kimim ?

Celiker BahceciMerhabalar, ben Çeliker BAHÇECİ. 2004 den beri özel sektörde bilgisayar mühendisligi ve egitmenlik yapıyorum. Yine aynı yılın Ekim ayından beri sitemde .Net ile programlama ve hayat görüşüm ile ilgili makalelerimi yayınlıyorum. Blogum dışında Yazgelistir.com, mobilnedir.com gibi ineta kapsamındaki bir çok siteye Microsoft teknolojileri ile ilgili yazılar yazmaktayım.
Bu site ile sizinde hayatınızı anlamlandırmanızda bir parça katkımın olması dilegiyle...


Arşiv